MikroTik - Два провайдера / Резервування та балансування

Схема VPN мережі аптек

Технічне завдання:

Реалізувати MultiWAN на маршрутизаторі MikroTik

Забезпечити:

  • Резервування підключення до Інтернет через декількох провайдерів
  • Розподілення навантаження між провайдерами
  • Доступ до маршрутизатора через декілька зовнішніх канала

Приклад реалізації

Winbox - New Terminal

			

# Налаштувуємо мережі провайдерів
/ip address add address=31.128.x.x/25 interface=ISP1
/ip address add address=193.110.x.x/25 interface=ISP2

# Налаштувуємо локальний інтерфейс
/ip address add address=10.0.1.65/27 interface=LAN

# Приховаємо NAT все що виходить із локальної мережі
/ip firewall nat add src-address=10.0.1.65/27 action=masquerade chain=srcnat

#Помітимо кожне зєднання що прийшло зовні і адресоване нашому роутеру
/ip firewall mangle add action=mark-connection chain=input in-interface=ISP1 new-connection-mark=cin_ISP1
/ip firewall mangle add action=mark-connection chain=input in-interface=ISP2 new-connection-mark=cin_ISP2

#Щоб відповідати через ті ж інтерфейси, звідки прийшли запити, поставимо відповідну роутинг-марку на кожне з'єднання
/ip firewall mangle add action=mark-routing chain=output connection-mark=cin_ISP1 new-routing-mark=rout_ISP1 passthrough=no
/ip firewall mangle add action=mark-routing chain=output connection-mark=cin_ISP2 new-routing-mark=rout_ISP2 passthrough=no

#Додамо default gateway в кожну з промаркованих таблиць маршрутизації
/ip route add distance=1 gateway=31.128.x.x routing-mark=rout_ISP1 check-gateway=ping
/ip route add distance=1 gateway=193.110.x.x routing-mark=rout_ISP2 check-gateway=ping

#failover через другого провайдера для кожного з шлюзів
/ip route add distance=2 gateway=193.110.x.x routing-mark=rout_ISP1
/ip route add distance=2 gateway=31.128.x.x routing-mark=rout_ISP2

#використовуючи PPC розділимо трафік на дві групи за вих. адресою і порту
/ip firewall mangle add src-address=10.0.1.65/27 action=mark-routing chain=prerouting new-routing-mark=lan_out_ISP1 per-connection-classifier=src-address-and-port:2/0
/ip firewall mangle add src-address=10.0.1.65/27 action=mark-routing chain=prerouting new-routing-mark=lan_out_ISP2 per-connection-classifier=src-address-and-port:2/1

#додамо default gateway в кожну з промаркованих для LAN трафіку таблиць маршрутизації
/ip route add distance=1 gateway=31.128.x.x routing-mark=lan_out_ISP1 check-gateway=ping
/ip route add distance=1 gateway=193.110.x.x routing-mark=lan_out_ISP2 check-gateway=ping

#failover через другого провайдера для кожного з шлюзів
/ip route add distance=2 gateway=193.110.x.x routing-mark=lan_out_ISP1
/ip route add distance=2 gateway=31.128.x.x routing-mark=lan_out_ISP2

Трафік через провайдера 1

Трафік через провайдера 2

Трафік LAN


Замовити налаштування роутера MikroTik